Browsers Connecting to SegPay Need to Support TLS 1.2 by June 1st, 2018

Earlier this year SegPay upgraded to the latest encryption technology (known as TLS 1.2) for protecting sensitive data transmitted between SegPay and our banks and other financial partners. This means that when you make a payment through SegPay, your data is protected with state-of-the-art technologies that conform to PCI’s latest standards for data security.

Because older versions of today’s popular web browsers do not all incorporate TLS 1.2, we have continued supporting previous versions, TLS 1.0 and 1.1, to ensure that consumers on older browsers can still connect and make payments. However, this support is ending soon – on June 1st, 2018, to be exact.

What does this mean for you? Starting June 1st, consumers connecting to SegPay with browsers that do not support TLS 1.2 will not be able to successfully make payments. So it’s important that you notify your consumers, and ask them to upgrade to the latest version of their preferred browser.

Consumers can check if their current browser is affected by¬†opening this page. If the “Version” section looks like the image below, the browser is up-to-date and you don’t need to do anything:

If you do not see TLS 1.2 in the “Version” section, please upgrade to the latest version of your browser. We’ll post another reminder about this as we get closer to June.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s